Автор jarod, 30 марта, 2024, 11:00
В русской версии AliExpress обновили дизайн, мы обновили расширение, чтобы оно работало в новом дизайне. Ждем когда Google опубликует новую версию расширения.
цитата · ответить
Цитата:
Ждем когда Google
А файрфокс? Он тоже с гугля берет?
цитата · ответить
SMarkov писал:
Цитата:
Ждем когда Google
А файрфокс? Он тоже с гугля берет?
в файрфоксе насколько я понимаю щас не работает. просто Google в какой-то момент больше года назад поставил ультиматум разработчикам, что должны все срочно переписать свои приложение на использование Manifest V3, вместо текущего Manifest V2, и что скоро перестанут работать расширения на Manifest V2... мы переписали расширение на Manifest V3, а потом выяснилось что в файрфоксе его еще нет, а поддерживать две разных версии расширения опять, как это было в самом начале сейчас нет возможности...

а потом Google сказал что не будет выключать Manifest V2 еще непонятно сколько времени... вот так некрасиво у них получилось...
цитата · ответить
Цитата:
Manifest V3
В ФФ с версии 109 он есть. Но ФФ не видит обновления расширения...
цитата · ответить
SMarkov писал:
Цитата:
Manifest V3
В ФФ с версии 109 он есть. Но ФФ не видит обновления расширения...
значит в ближайшие дни появится и там )
цитата · ответить
jarod писал:
SMarkov писал:
Цитата:
Manifest V3
В ФФ с версии 109 он есть. Но ФФ не видит обновления расширения...
значит в ближайшие дни появится и там )
хотя видимо нет:

Ошибка: "/background/service_worker" is not supported
цитата · ответить
Цитата:
Ошибка: "/background/service_worker" is not supported

это да - но ФФ умеет background.scripts - типа того - и нашим, и вашим:
"background": {
"service_worker": "background.ts",
"scripts": ["background.ts"]
}
редактировалось 1 раз, последний раз 3 дня назад, 19:14
цитата · ответить

Отвечать в форуме могут только зарегистрированные и авторизованные пользователи. Авторизуйтесь или перейдите к странице регистрации, если Вы еще не зарегистрированы.
Тему читают: 1 гость